반응형
https://www.acmicpc.net/problem/5363
문제
어린 제다이들은 요다와 대화하는 법을 배워야 한다. 요다는 모든 문장에서 가장 앞 단어 두 개를 제일 마지막에 말한다.
어떤 문장이 주어졌을 때, 요다의 말로 바꾸는 프로그램을 작성하시오.
입력
첫째 줄에 문장의 수 N이 주어진다. 둘째 줄부터 N개의 줄에는 각 문장이 주어진다. 문장의 길이는 100글자 이내이다. 단어의 개수는 3개 이상이다.
출력
각 문장을 요다의 말로 바꾼 뒤 출력한다.
예제 입력 1 복사
4
I will go now to find the Wookiee
Solo found the death star near planet Kessel
I'll fight Darth Maul here and now
Vader will find Luke before he can escape
예제 출력 1 복사
go now to find the Wookiee I will
the death star near planet Kessel Solo found
Darth Maul here and now I'll fight
find Luke before he can escape Vader will
코드
#include <iostream>
#include <string>
#include <sstream> // stringstream
#include <vector>
#include <algorithm>
using namespace std;
int main() {
int test;
cin>>test;
cin.ignore();
for(int i=0; i<test; i++){
string str;
getline(cin, str);
vector<string> vec;
stringstream ss; // 공백 기준으로 문자열을 짜른다.
ss.str(str);
string word;
while(ss>>word){
vec.push_back(word);
}
for(int i=2; i<vec.size(); i++){
cout<<vec[i]<<" ";
}
cout<<vec[0]<<" "<<vec[1]<<"\n";
}
return 0;
}
|
cs |
반응형
'백준 > C++' 카테고리의 다른 글
[BaeKJoon/C++] 백준 11637 c++ 인기투표 (0) | 2022.02.20 |
---|---|
[BaeKJoon/C++] 백준 5585 c++ 거스름돈 (0) | 2022.02.19 |
[BaeKJoon/C++] 백준 1978 c++ 소수 찾기 (0) | 2022.02.16 |
[BaeKJoon/C++] 백준 5598 c++ 카이사르 암호 (0) | 2022.02.15 |
[BaeKJoon/C++] 백준 3059 c++ 등장하지 않는 문자의 합 (0) | 2022.02.14 |